ever wanted to play with freebsd ?

April 19, 2013 — Leave a comment

if you want to play around with freebsd here is a small intro:

  • download the cd iso from the website
  • create a new virtualbox machine all with the defaults
  • follow the freebsd installation process all with the defaults

if everything went fine you are presented with a shell after installation. to make it a bit more comfortable you may execute the commands below to create a user, configure the package repository and install kde4 ( if you prefer gnome or xfce check the documentation and adjust the commands below ):

bash
# in case you are behind a proxy
export http_proxy=[proxy]:[PORT]
# boostrap system for pkgng
cd /usr/ports/ports-mgmt/pkg
make
make install clean
# create the index
cd /usr/ports
make fetchindex
# set repository to use
export PACKAGESITE=http://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-9-stable/Latest/
# install x11 and desktop environment
pkg_add -r xorg
pkg_add -r kde4
pkg_add -r virtuoso
echo "exec /usr/local/kde4/bin/startkde" > ~/.xinitrc
# enabling hal and dbus for keyboard and mice detection
echo "hald_enable=\"YES\" " >> /etc/rc.conf
echo "dbus_enable=\"YES\" " >> /etc/rc.conf
# enable kdm autostart
echo "kdm4_enable=\"YES\" " >> /etc/rc.conf
# misc ( virtual box addons for getting a higher resolution when running 
# as virtual box guest )
pkg_add -r virtualbox-ose-additions
echo "vboxguest_enable=\"YES\" " >> /etc/rc.conf
echo "vboxservice_enable=\"YES\" " >> /etc/rc.conf
# add sudo
pkg_add -r sudo
# mount /proc filesystem
mount -t procfs proc /proc
echo "proc            /proc           procfs  rw      0       0" >> /etc/fstab
# adding a user
mkdir -p /home/testuser
pw group add testuser
pw user add -n testuser -d /home/testuser -g testuser -s /usr/local/bin/bash
chown testuser:testuser /home/testuser
passwd testuser
echo "exec /usr/local/kde4/bin/startkde" > /home/testuser/.xinitrc
echo "%testuser ALL=(ALL) ALL" >> /usr/local/etc/sudoers
# install some software
pkg_add -r vpnc
pkg_add -r rdesktop
pkg_add -r KeePassX
pkg_add -r firefox
# get security patches and updates
freebsd-update fetch
freebsd-update install
# reboot and have fun
reboot

happy freebsding:

which way to choose ?
which way to choose ?

No Comments

Be the first to start the conversation!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.